Jaguar I-Pace Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Loving the new car but have a few gripes:

1The remote app doesn't always show correctly the current state of charge.
2. Instances where car wouldn't remember my profile settings. Highly annoying to have to enter them all again. Radio favs, instrument sertings, dash.
3. An instance where it forgot my profile completely.
I had to make a new one.
4. Doesn't always carry out the settings from my profile, although profile is selected. i.e car seat position, car lowering when getting out. Wing mirrors not dipping, or they back to a default position.
5. Not playing iphone source through speakers altough all was connected through carplay.. wven tried bluetooth, no joy until I turned car on/off.
6. Car charging is not a straight forward procedure.
7. Charge display dissappears after a while.. you have to open door to get it back on again.
8. Sometimes locking door can dissconnect the charge.. very frustrating when you are using a public chargerand go into services. 30 min later the car has no charged at all.
9. Would like An off setting for cabin noise.
10. LKA is not very good.
11. Steering wheel buttons are terrible esp the jog.
12. Screen Menus need reworking.
13. Haven't dared to try setting charge precon. Or timers yet.
14. Very few places seem to have the rapid chargers that are compatible with i-pace in South Wales. ecotricity being one of them. it would take hours at the services. It took me 90min to get 15 miles extra range from an ecotricity non rapid charger today.

All that being said it's the best car I've ever driven if I just drive the thing, I hope they iron out all the faults in future updates and listen to their customers. I went to Jag Cardiff the other day to tell them about my charging issues and after 20 min wait without being seen by a tech. I walked out. I was also hoping they would have a rapid charger there too but no luck.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
After reading some posts on this forum I think the odometer adapts to the current temperature and driving style. I think others received their cars with about 280 miles worth of range.
 

·
Registered
Joined
·
389 Posts
The driving experience varies from owner to owner but every complaint or fault is a personal thing. I find it unbelievable sometimes that manufacturers tell us they have done a million real world miles and yet faults still make it into production and as far as customers. How can these faults not have been picked up. Do the test drivers just literally drive and that's it. Quite frankly I find it really disappointing. I mean come on Jaguar no one should be having issues charging an electric vehicle. The one thing you need it to do is charge and coming out from a 30min break to find the car hasn't charged is not acceptable. The touch pro has been around for quite a while now and they still can't get it right. No doubt I will love driving my car when I final receive it next year but Jaguar need to work hard at fixing these faults and fast. Their IT is laughable. I still experience problems connecting to my XE from the app, a service I now pay for since the car turned 3 years old. I certainly don't expect Jaguars latest model to be having the same problems.
 

·
Registered
Joined
·
16 Posts
Can anyone help
I am trying to charge at home from a 13amp socket.
Every time I lock the car to go into the house charging stops. Opening the car again the information displays "initialising" eventually starts charging then stops again.
Am I doing something wrong or is there a fault?
 

·
Registered
Joined
·
81 Posts
There are those who say that you should:

1) Close and lock your I-Pace. Then unlock the car.

2) Plug your charger into the wall (if needed).

3) Open the charge door and then plug into the car

4) Lock your car with the remote.

(Don't forget to unlock the car before trying to remove the charging cable - or you'll set off the alarm.)
 

·
Registered
Joined
·
1,098 Posts
And check the departure time is not to far.
Yesterday I tried to charge the I pace but it was displaying scheduled charge in blue then preparing charge in white.
My next departure time was monday at 7.
So I turned it off, unplugged and replugged the car and it charged all night
 
1 - 9 of 9 Posts
Top