WattCat - InControl remote app for Android early access

All Jaguar I-Pace related discussions
qqiao
Posts: 42
Joined: Mon Mar 18, 2019 2:29 pm
Location: United States

Re: WattCat - InControl remote app for Android early access

Post by qqiao » Fri Jun 14, 2019 9:13 pm

I think I reported this issue on Google play. With my phone, the 3 icons: charging, parked and locked, they don't seem to space evenly.

This is probably a nitpick, but I'm a little bit of a James May.

Screenshot_20190614-160745__01.jpg

Last edited by qqiao on Fri Jun 14, 2019 10:26 pm, edited 1 time in total.
2019 IPace FE. Corris grey exterior. Oyster white interior.


ardevd
Posts: 377
Joined: Mon Dec 24, 2018 12:30 am
Location: Norway

Re: WattCat - InControl remote app for Android early access

Post by ardevd » Fri Jun 14, 2019 9:50 pm

Thanks for reporting the issue. I'm seeing the same thing and will address it at some point :) it bothers my OCD... A lot! ^^
Control your I-Pace with jlrpy | I-PACE HSE Ebny Prem Txt MY2019.

Telematics: N/A | InControl: S19A_19.11.4-330884


wh05apk
Posts: 40
Joined: Sat Apr 13, 2019 4:38 pm
Location: United Kingdom

Re: WattCat - InControl remote app for Android early access

Post by wh05apk » Sat Jun 15, 2019 5:41 am

Looking good, but tyre pressures now showing 145psi.


ardevd
Posts: 377
Joined: Mon Dec 24, 2018 12:30 am
Location: Norway

Re: WattCat - InControl remote app for Android early access

Post by ardevd » Sat Jun 15, 2019 7:02 am

wh05apk wrote:
Sat Jun 15, 2019 5:41 am
Looking good, but tyre pressures now showing 145psi.
Could you switch to Bar and see if it shows up correctly then?
Control your I-Pace with jlrpy | I-PACE HSE Ebny Prem Txt MY2019.

Telematics: N/A | InControl: S19A_19.11.4-330884


wh05apk
Posts: 40
Joined: Sat Apr 13, 2019 4:38 pm
Location: United Kingdom

Re: WattCat - InControl remote app for Android early access

Post by wh05apk » Sat Jun 15, 2019 8:29 am

Showing as 10 bar


fantonsen
Posts: 16
Joined: Thu Mar 28, 2019 8:26 am
Location: Norway

Re: WattCat - InControl remote app for Android early access

Post by fantonsen » Sat Jun 15, 2019 9:01 am

fantonsen wrote:
Fri Jun 14, 2019 8:01 am
Mine is also off, but not by this much.

The pressure in app shows 2.4 - 2.5 bar.
And the same time in the car, it shows 2.6 - 2.7 bar.

At least, it is the same 2 tires that shows the highest values in both places. So the values seems to be off by 0.2 bar.
ardevd wrote:
Fri Jun 14, 2019 4:59 pm
sciencegeek wrote:
Fri Jun 14, 2019 3:41 pm
Small differences are most likely due to the car reporting the tire pressure to the API (which is the value you see in the app) at a different time from when you read it in the car.
Agreed!
This is strange.

* I did a new test today. Went into the car, and checked the pressures in all different units.
* Then I went to the official InControl-app to have it trigger updates from the car.
* Then again to the WattCat app, and noticed the same 0.2 bars values below the "truth" in the car. (I guess the car has the correct values???)
* And finally I called the get_status() in the API and saw the same values as in the WattCat-app!

The values in the car: 2.6 bar on all tires. kPa from 255 to 261. (Is kPa = bar * 100 ? )

The app shows 2.4 bar on all tires.

The APi get_status() is shown below, with values between 236 and 242, and the date is updated with correct timestamp from my inspection from today. (I guess this must be kPa-values ? )

So my conclusion here is that the WattCat-app shows correcly the values from the API, but the API somehow has wrong values even though the lastUpdatedTime seems updated and correct.

I want to note that I have not refilled my tires in a long time, and the values the last months have varied between 2.6 and 2.9 bar in the car (depending on temperatures). I have never seen values as low as 2.4 in the car, so this is very strange.

{
'vehicleStatus' : [{
'key' : 'TYRE_PRESSURE_REAR_RIGHT',
'value' : '236'
}, {
'key' : 'TYRE_PRESSURE_FRONT_RIGHT',
'value' : '242'
}, {
'key' : 'TYRE_PRESSURE_FRONT_LEFT',
'value' : '240'
}, {
'key' : 'TYRE_PRESSURE_REAR_LEFT',
'value' : '242'
}
],
'lastUpdatedTime' : '2019-06-15T07:08:48+0000'
}
🇳🇴 Norway
:arrow: I-Pace S | Firenze red | Delivered September 2018


fantonsen
Posts: 16
Joined: Thu Mar 28, 2019 8:26 am
Location: Norway

Re: WattCat - InControl remote app for Android early access

Post by fantonsen » Sat Jun 15, 2019 9:10 am

To follow up my previous post:

Shortly after the previous data, I took the car out for a short drive in the warm temperatures today.
The pressure shown in the car soon increased to 2.8 bar.
I also checked the tire-pressures manually on a gas-station, and it was also at 2.8 bar. So the values in the car is spot on correct.

The WattCat-app also increased the values, but only up to 2.6 bars. So this is constantly 0.2 bars below the correct values.

And the API confirms the trend:

Why on earth does the API constantly report tire-pressure values about 20 below the correct values?
Is this only my car, or has any one else seen something like this?

{
'vehicleStatus' : [{
'key' : 'TYRE_PRESSURE_REAR_RIGHT',
'value' : '255'
}, {
'key' : 'TYRE_PRESSURE_FRONT_RIGHT',
'value' : '261'
}, {
'key' : 'TYRE_PRESSURE_FRONT_LEFT',
'value' : '259'
}, {
'key' : 'TYRE_PRESSURE_REAR_LEFT',
'value' : '259'
}
],
'lastUpdatedTime' : '2019-06-15T08:02:00+0000'
}
🇳🇴 Norway
:arrow: I-Pace S | Firenze red | Delivered September 2018


ardevd
Posts: 377
Joined: Mon Dec 24, 2018 12:30 am
Location: Norway

Re: WattCat - InControl remote app for Android early access

Post by ardevd » Sat Jun 15, 2019 10:55 am

fantonsen wrote:
Sat Jun 15, 2019 9:10 am
To follow up my previous post:

Shortly after the previous data, I took the car out for a short drive in the warm temperatures today.
The pressure shown in the car soon increased to 2.8 bar.
I also checked the tire-pressures manually on a gas-station, and it was also at 2.8 bar. So the values in the car is spot on correct.

The WattCat-app also increased the values, but only up to 2.6 bars. So this is constantly 0.2 bars below the correct values.

And the API confirms the trend:

Why on earth does the API constantly report tire-pressure values about 20 below the correct values?
Is this only my car, or has any one else seen something like this?

{
'vehicleStatus' : [{
'key' : 'TYRE_PRESSURE_REAR_RIGHT',
'value' : '255'
}, {
'key' : 'TYRE_PRESSURE_FRONT_RIGHT',
'value' : '261'
}, {
'key' : 'TYRE_PRESSURE_FRONT_LEFT',
'value' : '259'
}, {
'key' : 'TYRE_PRESSURE_REAR_LEFT',
'value' : '259'
}
],
'lastUpdatedTime' : '2019-06-15T08:02:00+0000'
}
Thanks for the info! I've forwarded it to my contact at JLR API team. Hopefully they will be able to dig up some answers. Its really strange that the API consistently reports lower values than the vehicle does though.
Control your I-Pace with jlrpy | I-PACE HSE Ebny Prem Txt MY2019.

Telematics: N/A | InControl: S19A_19.11.4-330884


kermit68
Posts: 48
Joined: Sat Sep 15, 2018 1:06 pm
Location: Rome / Italy

Re: WattCat - InControl remote app for Android early access

Post by kermit68 » Sat Jun 15, 2019 11:03 am

ardevd wrote:
Sat Jun 15, 2019 10:55 am
fantonsen wrote:
Sat Jun 15, 2019 9:10 am
To follow up my previous post:

Shortly after the previous data, I took the car out for a short drive in the warm temperatures today.
The pressure shown in the car soon increased to 2.8 bar.
I also checked the tire-pressures manually on a gas-station, and it was also at 2.8 bar. So the values in the car is spot on correct.

The WattCat-app also increased the values, but only up to 2.6 bars. So this is constantly 0.2 bars below the correct values.

And the API confirms the trend:

Why on earth does the API constantly report tire-pressure values about 20 below the correct values?
Is this only my car, or has any one else seen something like this?

{
'vehicleStatus' : [{
'key' : 'TYRE_PRESSURE_REAR_RIGHT',
'value' : '255'
}, {
'key' : 'TYRE_PRESSURE_FRONT_RIGHT',
'value' : '261'
}, {
'key' : 'TYRE_PRESSURE_FRONT_LEFT',
'value' : '259'
}, {
'key' : 'TYRE_PRESSURE_REAR_LEFT',
'value' : '259'
}
],
'lastUpdatedTime' : '2019-06-15T08:02:00+0000'
}
Thanks for the info! I've forwarded it to my contact at JLR API team. Hopefully they will be able to dig up some answers. Its really strange that the API consistently reports lower values than the vehicle does though.
I noticed the same behaviour. It's like Jaguar is using a conversion factor less than 100 to convert readings in KpA to Atm
MY20 Yulong White SE, 20", air suspension, privacy glass, black pack and other fine stuffs


User avatar
Billyboy106
Posts: 8
Joined: Sat Jun 15, 2019 3:39 pm
Location: North Worcestershire

Re: WattCat - InControl remote app for Android early access

Post by Billyboy106 » Sat Jun 15, 2019 6:15 pm

This looks really interesting and appears to address some shortcomings in remote and android auto

I’m enjoying the incar software although flaky in places

Any chance of still joining the testing program? Forum doesn’t want me to private message as a new user

Billyboy
May 19 ipace in photon red, oyster interior, black pack, air suspension, 18” wheels


Post Reply

Return to “Main Jaguar I-Pace chat”